Solved

Frehservice Alerts integration with SolarWinds

  • 2 September 2021
  • 2 replies
  • 26 views

Userlevel 1

Hello, 

I’m having difficulties configuring the integration between Freshservice Alerts and SolarWinds.

I used this documentation:

https://support.freshservice.com/support/solutions/articles/50000002747-integrate-solarwinds-npm-with-freshservice-alert-management

When trying to simulate the alert SolarWinds says that ‘action executed successfully’ but the test alert is not created in the alerts section in Freshservice.

API reference at https://api.freshservice.com/#introduction shows CURL examples only for tickets, changes etc. but not for Alerts.

Can anyone suggest how can I debug the configuration using CURL or some other method?

Has anyone successfully configured the integration with SolarWinds? 

Any gotchas you experienced during the integration setup?

Thanks!

P.S.

I’m not a developer. 

 

icon

Best answer by Glavin Crasta 5 September 2021, 19:51

View original

2 replies

Userlevel 3

Hi @JiriGrohmann ,

The endpoint URL for Alerts module would be available within the alert integration profile itself. Please enable Alert management on your instance. Post that go to Alert profiles → New profile → Add integration and choose SolarWinds. You would get the API and authorization credentials as below under step 4.

You could try out the alert initially from Postman by triggering a POST message to the Alert endpoint given in step 4 and adding the authorization header as well. Post the body from the suggested template from step 1 in above page.

Userlevel 1

Hello, @Glavin Crasta ,

thanks. It turned out that the ‘copy’ button in the ‘Auth header’ omits the word ‘Authorization’

 

As soon as I amended the command as per below SolarWinds started triggering alerts.

<“C:\Program Files\curl-7.78.0-win64-mingw\bin\curl.exe -X POST -H "Authorization: auth-key XXX ….”>

Credit also goes to Raja Pavankumar from FS support who helped to the missing ‘authorization’.

@Glavin Crasta and yes, looks like I’ll have to start using Postman - thanks for pointing that out.

Reply