Backspace removes additional space after removing word



Show first post
This topic has been closed for comments

112 replies

Just confirming that this was fixed for me for many months and now I see it but sporadically. I can't get it to happen on purpose so i can't say that it is fixed or not. I know I saw it happen today again a few times.


I just updated Chrome from 

Version 74.0.3729.169 (Official Build) (64-bit) to 

Version 75.0.3770.80 (Official Build) (64-bit)

I'll monitor this week to see if it happens again.


Yep, it started happening for me as well. Google Chrome, Windows 10.

BTW, this page is one of the top results when you search "backspace erases trailing space"


We are noticing this problem frequently.  Is this happening in the latest version of chrome ( 75 )?


Hey moderators, this is NOT solved.  Still happening.  I even went to the trouble of attaching a GIF to show it.


Why are you suppressing my comments, and why is this marked as being solved?


It happens inconsistently. What is the deal with this.


@GreggZimmerman - I don't doubt you. It used to be 100% of the time for me then it was fixed, for some time, and then I started seeing it happen occasionally.

And no need to slander Freshworks engineering. I'm sure they are concerned about this but as I understand it, it is more complex than it seems. I'm sure your company has had times where it had a bug that your customers didn't know the underlying complexities, dependencies, etc.


That said, i hope there is a fix for this soon. it is really annoying.

Regards

Craig


The underlying issue is that Freshworks is labeling this as Solved when it is not.  If they are looking at their own list of tickets, this one isn't likely to get any attention because of that.  My hopes are also dim.  I would be slightly more hopeful if at least they would remove that label.  Just like my own ticket system, the items that are listed as Solved aren't getting any attention.


image



I really wish a Freshworks person would chime in as to why they are labeling this as Solved, when it is clearly not.


Yes, I know, it was Solved, as far as we all knew and then it started happening again.

I agree that someone fro Freshworks should chime in though.


Awesome! This annoying little thing is back now-- been happening again for at least the last 2-3 wks.


Please, for the love of all that is holy, stop this from happening... again. 


Badge +5

The issue was never solved for me.


I opened a ticket with Freshdesk support asking why this issue was marked as solved. After a bit of a run-around, it was assigned to @Aravind S


Still, no change...


Badge +5

Still nothing?  Wow.


It is ironic that this was first reported in a post titled "FreshDesk is Listening... Backspace NOT Working Correctly"

https://support.freshdesk.com/support/discussions/topics/325191


Freshdesk is certainly not listening.  In fact, I opened a ticket on this subject that is going nowhere.  New title: "Freshdesk is Ignoring".


OMG OMG OMG!!!


I figured out why this isn't being fixed! I just learned today that it is unnecessary to place two spaces after a period, exclamation or question mark. Look it up for yourself if you are throwing up your hands. It's crazy. I feel like I am learning to type all over again now because all my keyboarding and computer classes taught two spaces.


Now, this makes sense why this is happening. It was actually auto-correcting!


So, the question is now, why they heck didn't anyone else mention this?


So, any chances this will ever actually be fixed? 


I think the question now should be. "Is there really anything to fix?" I guess that depends on whether you type one or two spaces after sentence-ending punctuation.


This has nothing to do with sentence ending punctuation, but single spaces between words during normal typing. Let's say I change my mind about a word choice, and try to change it, the preceding space is deleted and then I'm just creating typos. 


So yes, there is still a major bug that needs to be fixed. 


To be clear, this has been an annoyance to me because I used to type two spaces after ending punctuation. Freshdesk would always remove one of the spaces if I ever tried to correct typing after it. Now that I am typing like a modern typist (one space after ending punctuation), I have no issues at all. So, I will just agree to disagree with you here that it really does have to do with ending punctuation.


@Anton if you are seeing it behave differently, could you provide a screen recording of what you are seeing? I think that is the most helpful when trying to communicate about this nasty thing.


Anton is correct, the issue does not only occur at the end of a sentence. Your choice to place one or two spaces after the end of a sentence doesn't really have anything to do with this bug, which at one time Freshworks acknowledged and fixed, but is now happening again.


@Dave can you show us a screen recording?


Here is a screen capture (this is while replying to an email). 




@Eric- why do you guys keep asking for screen recordings. I know it has been provided many times by others. The issue is the same as when it was first reported. It happens randomly for me (less so now than long ago) but when it starts happening, it seems to keep happening until it doesn't but no clear reason why.


I believe there is a new/improved editor coming soon or just new features. Will that possibly address this?


Yeah, this is what I used to see too. I haven't seen that in a while though. I tried to recreate it and couldn't. I usually saw most of these annoyances while replying to a ticket.


You mentioned that you were replying to an email. Can you tell us specifically which screen you are typing in? I have seen this auto-crap work differently depending on where it is being typed.


Also, which browser are you using, and which version? 


(Hey Freshworks, don't rush in to help out, take your time... /s)


It happens to me in both Chrome 77.0.3865.120 and in Safari 13.0.2 as of today. 


I was replying to a ticket by hitting the "reply" button in response to an email, and typing within the automatically generated response area (automatically creating the salutation, and inserting my signature). 

It did not happen if I created an email from scratch, and does not happen if I remove the automatically generated content. 


@Craig- I asked for screen recordings because now I can't re-create the problem, while weeks ago I could recreate it all the time. I wanted to make sure we are all talking about the same thing. Not a "Well, prove it!" kind of thing, I just wanted to see it. Also, I noticed in that screen recording that there was some kind of popup that showed an autocorrect with an X on it. You see that?


There must be a reason why this stops, and then why it exists. I noticed that this issue isn't consistently happening in all context, so I think it is important to note what screen this was happening on, and also what browser version was being used.


The auto correct "x" at the end of the video is the Mac operating system trying to compensate for the missing space. That is their autocorrect interface.