Backspace removes additional space after removing word


I have an annoying issue where, when I delete a word using the backspace, the preceding space is also deleted.

The environment I am in is the description field, replying to or creating a new ticket. Please see the attached video.



This topic has been closed for comments

112 replies

@davidred @progenix @yashameta -  Our devs are working on this, analyzing the reason for this issue resurfacing on a few instances, yet again.

That said, would you mind sending us an email at mentioning this?

We should then be able to provide you with timely updates on this.


having the same issue with me also while writing the articles.


I too am having this issue for about two weeks now.


Backspacing the first letter of a new word appears to remove the space, but there are some oddities I’ve noticed.

  • After it removes the space, typing any letter makes it appear without a space
  • After it removes the space, pressing backspace once more does nothing, as if removing an invisible backspace

For a while I was thinking there was something wrong with my keyboard.

We have the same issue. CTRL+ Backspace is simply not an option, you don't expect a space between words being removed when you remove the word (or just a few letters of it), because you made a typo. Please fix this, it's driving me insane!


We understand the inconvenience caused.

We did face an issue with the backspace key removing the preceding space as well, most of which related to a then bug on the reply editor that was specific to the Firefox browser. If you are using other browsers and still seem to come across this, please write to us at

Our support stars are happy to analyze it and fix the same for you.


I am screamingly mad about this today... it's just driving me crazy. Especially if you want to finish an email 5 mins before leaving the office...
I am so angry, I could bite a piece off my desk. Please have someone look into it.

This is still ongoing. All of my team are on furlough right now, and I need to be working at maximum efficiently in order to stay on top of 5 peoples workload by myself. This issue is causing me needless delay in a time where every second counts. Will be very much looking forward to this finally getting resolved.

still this issue is highly annoying, happens to me almost on a daily basis ... when is it going to be fixed? do you even care??

Badge +2

Issue still happening intermittently but frequently.
Can confirm this is happening on Chrome with the following OS's: (with all plugins/extensions disabled)

MacOS 10.13.6
Win7 (latest)

Win10 v1909

Is there any update on getting this resolved?  We are still having the issue intermittently.  

Badge +5

Thank you @Karthik for reopening this investigation. This continues to be a major daily annoyance for me.

In a recent session with @Sandeepwe confirmed that the issue is reproducible in my environment all the time in all browsers, but we have determined that it does not affect other Freshdesk instances. Sandeep can confirm this and has access to my instance for testing.

This may suggest that a setting, app, Freshplug, or something similar is the trigger.

Just to be clear, there are two issues discussed in this thread:

1. Backspace in a sentence which is preceded by two spaces results in one space being removed.

2. Backspace to the beginning of a word and the space before the word disappears.

I can always reproduce issue 1. I have seen issue 2 (including today), but cannot always reproduce it.

Badge +6

The backspace issue is something we're hearing from a lot of our customers. Therefore, we're marking this thread as unsolved as the issue has arisen again.

We're working on identifying the cause of the issue to fix it quickly. It'd be great if you can tell us about when the backspace issue happens for you so that we can replicate and fix it.

Badge +6


I’m Karthik from the Freshdesk product team. Here's what has been happening with the backspace issue:

Earlier this year, we came across a bug in the reply editor (Froala) that we solved with a fix of our own. Later, Froala provided a fix that we incorporated in Freshdesk. In these cases, the issue was reproducible by us: we identified the cause, figured out the solution, fixed the problem, and marked the community thread as resolved.

However, the recent backspace issue has been extremely sporadic.  We’re yet to identify the scenario(s) where hitting the backspace causes an inconsistent cursor behavior. 

We understand your frustration with this issue. Please be assured that we’re doing all that we can to resolve this as soon as possible.  It'd be really useful if you can tell us the scenarios (with browser details) where the backspace issue happens to you. We'll try recreating them to identify why this is happening.

Hope this was helpful,


Badge +5

Just to be clear, this conversation points out two similar issues with the editor plus a series of general issues with Freshdesk in general.


1. When deleting a word, it also deletes the space before it. A great recording of that was posted yesterday by @AntonRiehl

2. If you press backspace in any text following a sentence ending in a period and two spaces, it removes one of the spaces. I provided a GIF of that some time ago:

The general issues with Freshdesk include:

- The possibility that these "features" have been applied intentionally, as some have suggested.

■ Freshdesk often imposes changes that are not beneficial to all, yet does so globally without offering a configuration to opt out.

■ Product development wastes time on "one size fits all" enhancements that reduce productivity.

■ Nobody from Freshdesk has indicated that this is intentional.

- Ignoring issues.

■ The issue is marked as resolved. Even though many have indicated that the problem persists, there is no acknowledgement by Freshdesk in this channel. I know that they are aware of it because I made sure of that.

■ Even when confronted with issues, documented and explained, they do not address them. Instead of focusing energy on developing new, unwelcome changes, they should pause and fix things that people are complaining about.

■ Issues are documented and explained to one agent and the next agent says that he/she has never heard of it and you must start over.

@CraigConover - I don't "slander" Freshdesk engineering. As a paying customer, I hold them to the same standards that my company has for our customers. We program in all of the same environments and more, yet we fix things in a fraction of the time.

The link to the screen in the recording in my last reply looks like this:


@Eric- I understand. It is not easy to reproduce as it seems to be random but there has to be a pattern. For some, it is frequent or all the time. I just so happened to reproduce it, reliably (by accident), in the chatbot training screen. See attached file.

Hope that help isolate the scenario.

The auto correct "x" at the end of the video is the Mac operating system trying to compensate for the missing space. That is their autocorrect interface. 

@Craig- I asked for screen recordings because now I can't re-create the problem, while weeks ago I could recreate it all the time. I wanted to make sure we are all talking about the same thing. Not a "Well, prove it!" kind of thing, I just wanted to see it. Also, I noticed in that screen recording that there was some kind of popup that showed an autocorrect with an X on it. You see that?

There must be a reason why this stops, and then why it exists. I noticed that this issue isn't consistently happening in all context, so I think it is important to note what screen this was happening on, and also what browser version was being used.

It happens to me in both Chrome 77.0.3865.120 and in Safari 13.0.2 as of today. 

I was replying to a ticket by hitting the "reply" button in response to an email, and typing within the automatically generated response area (automatically creating the salutation, and inserting my signature). 

It did not happen if I created an email from scratch, and does not happen if I remove the automatically generated content. 

Yeah, this is what I used to see too. I haven't seen that in a while though. I tried to recreate it and couldn't. I usually saw most of these annoyances while replying to a ticket.

You mentioned that you were replying to an email. Can you tell us specifically which screen you are typing in? I have seen this auto-crap work differently depending on where it is being typed.

Also, which browser are you using, and which version? 

(Hey Freshworks, don't rush in to help out, take your time... /s)

@Eric- why do you guys keep asking for screen recordings. I know it has been provided many times by others. The issue is the same as when it was first reported. It happens randomly for me (less so now than long ago) but when it starts happening, it seems to keep happening until it doesn't but no clear reason why.

I believe there is a new/improved editor coming soon or just new features. Will that possibly address this?

Here is a screen capture (this is while replying to an email). 

@Dave can you show us a screen recording?

Anton is correct, the issue does not only occur at the end of a sentence. Your choice to place one or two spaces after the end of a sentence doesn't really have anything to do with this bug, which at one time Freshworks acknowledged and fixed, but is now happening again.

To be clear, this has been an annoyance to me because I used to type two spaces after ending punctuation. Freshdesk would always remove one of the spaces if I ever tried to correct typing after it. Now that I am typing like a modern typist (one space after ending punctuation), I have no issues at all. So, I will just agree to disagree with you here that it really does have to do with ending punctuation.

@Anton if you are seeing it behave differently, could you provide a screen recording of what you are seeing? I think that is the most helpful when trying to communicate about this nasty thing.