Backspace Removing Extra Space-- AGAIN...

  • 7 September 2019
  • 1 reply
  • 33 views

This really should be an extension to this discussion: https://support.freshdesk.com/support/discussions/topics/324891?page=1

However, it looks like FD folks have gone silent there, so I am starting a new topic for this old issue.


The title mostly covers it-- backspacing sucks again. When backspacing back to the first letter of a word, it will then auto-delete the space between that word and the previous one.


Seems like a small issue, but it when you think about how much backspace is used (particularly if you suck at typing - ie. me), then the added time of correcting this extra deletion is infuriating. 


Please go back in and fix this bug... again.

Saira Tehreem 1 year ago

Hi @craig_16293 ,

Sorry for not getting back to you sooner! Please understand that our devs are already working on the same, You can expect a fix in the near future!

However, for now, here are some workarounds that could probably help!

  1. Check the agent reply template and if there are any empty lines, please delete them and use just Enter to again insert the line space to the template.
  2. Agents should not use shift+enter to leave a line space when typing replies manually, they should just use Enter.
  3. In cases where there are any frequently used canned responses, it is advisable to follow step 1 for the canned responses too.
  4. The issue is only reproducible with the latest Chrome version.

Kindly note, This seems to happen when we use Shift+Enter to leave line space in the agent reply template. Froala editor usually converts the empty whitespaces at the end of a <p> div to &nbsp; but it fails when shift+enter is used. In this case, the usual behavior is altered and the <p></p> tag does not gets created, and hence the &nbsp; conversion fails.

We hope the workarounds are useful! Feel free to drop your comments.

 

View original

1 reply

Userlevel 1
Badge +5

Hi @craig_16293 ,

Sorry for not getting back to you sooner! Please understand that our devs are already working on the same, You can expect a fix in the near future!

However, for now, here are some workarounds that could probably help!

  1. Check the agent reply template and if there are any empty lines, please delete them and use just Enter to again insert the line space to the template.
  2. Agents should not use shift+enter to leave a line space when typing replies manually, they should just use Enter.
  3. In cases where there are any frequently used canned responses, it is advisable to follow step 1 for the canned responses too.
  4. The issue is only reproducible with the latest Chrome version.

Kindly note, This seems to happen when we use Shift+Enter to leave line space in the agent reply template. Froala editor usually converts the empty whitespaces at the end of a <p> div to &nbsp; but it fails when shift+enter is used. In this case, the usual behavior is altered and the <p></p> tag does not gets created, and hence the &nbsp; conversion fails.

We hope the workarounds are useful! Feel free to drop your comments.

 

Reply