Cursor randomly jumps back to start in reply

  • 8 February 2018
  • 49 replies

Show first post
This topic has been closed for comments

49 replies


I recognise the issue discussed in this forum, but from a different context. Since about a week ago I find when I start to write a new ticket, the cursor will jump back to the beginning, while I am typing, causing the text to appear jumbled.


Still happening here as well, not necessarily for canned responses, but definitely happens when we use ticket templates.

This is still driving me nuts and still happening in almost every single ticket :(

Userlevel 3
Badge +10

@Steven@Taz@Ian We've noticed a couple of instances where the cursor behaves strange. When you start typing with a line break (by hitting 'Enter'), the cursor switches back to the previous position. The other one is when you add an inline image, at times, the cursor seems to jump below the signature (if the signature has an inline image).

We'll be addressing both these issues soon and aim to make the editor experience better, in general.


@Aravind, I think it does it in relation to the in-browser spell check as well. I thought it was due to Grammarly, but upon switching it off in the hopes of reducing frustration, no luck.

I noticed the way Canned Responses are used has changed, but the issue with / creating multiple duplicates of your message (and removing most of the spaces to make one giant paragraph) still occurs regardless:

It has been a while since it did it to the point it crashes my entire browser though, so that's a bonus =)

Badge +3

I have this issue as well when trying to update the description of a ticket.  It is very annoying.  This bug has been here over a year with no solution?  Not impressive.  I would think that Freshdesk would care more about their customers than to ignore an issue for that long.

Our agents are reporting this same cursor issue while adding notes. See attached image on what a note looks like when it happens. The user was typing 'Missing dealer tax.'. We are using Chrome with the new mint interface. 


@Erikt I have the same issue, still, not sure why this topic is marked as solved. Maybe we need to flood the place with new topics on this to get some traction?

Please change the status of this ticket to open. I experience the problem every day in Freshdesk. I start writing a ticket and the cursor jumps back to the beginning, so that my text appears jumbled. Been going on for months. I'm using Mint in Google Chrome.

Badge +2

@Ronand Kallen : We had deployed a fix for the random movement of the cursor while typing out a reply. However, in case if you're trying to insert a canned response/solution, it might not end up in the likely position and that has already been acknowledged as a bug.


Try flushing out the browser cache/cookies and see if the issue still persists. If yes, please drop us a note here and we'll try to understand the trigger movement behind the issue in your helpdesk.



Having the same issue here on multiple PCs. Looking forward to having this fixed.

Again - issue still exists today. 

Badge +3

@Aravind S It is awkward that you have not yet reopened this persistent issue. I had it today.

BTW - If you are looking to reproduce this, do the following:

  1. Click to edit the ticket description
  2. Click into the description
  3. Use your arrow keys to move to another cursor location
  4. Type

Result: The cursor jumps back to the beginning of text.

Note that #2 is the key. If you click again or do not move with the arrow keys it will mot occur. @Freshdeskmay consider this a work-around but it just punishes people who prefer to use the keyboard. They are likely going to forget it each time and only look up in time to see that they have been wasting their time.

This awkward functionality is not acceptable once identified. The fact that it has gone unresolved for over 16 months is embarrassing. In that amount of time, any self-respecting software company could have grown an effective programmer in a high school science lab.


Also still experiencing this issue. Mostly notice it while modifying replies when using templates.

Badge +2

Also experiencing this.
Extremely frustrating issue!

Please fix ASAP!!

I still experience this problem every day with Freshdesk, and it's not just in replies, but when I write new tickets too. It makes me angry enough that you don't fix the problem, that you ignorantly keep this topic on 'solved' status is infuriating.

Userlevel 5
Badge +9

This should ideally not happen, @marrrysmits. Can you please share/DM us your Freshdesk account details to have this checked further? It wouldalso be great if you can try the above suggestions shared by Naresh and let us know if it helps.



I recommend everyone creates individual support tickets on this issue and touches base weekly. I'm just starting to do this myself for this issue and another.

You can do this from the chat/bot in the bottom right-hand corner.

Badge +3

Yes, I have this issue in many editor boxes. I had it while trying to create a ticket template earlier today.

@Taz- good idea about the tickets, but I have little faith that this will be fixed any time soon. It has already been ignored for over a year. It is my experience that Freshdesk is too busy creating new bugs to fix old ones.

Badge +2

Still being driven insane by this issue every single day, (along with the backspace issue)

Just experimenting but I turned off Keyboard Shortcuts (from selecting account picture at top right of page) and so far it is not giving me the issue...

Will continue to monitor and report back in a few days if I can.

Didn't even know that was an option, will check it out @Hono C. The Keyboard Shortcuts are useless anyway since you can't do everything with just those eh

Badge +2

Unfortunately the issue persists even when Keyboard Shortcuts are turned off.

Yes, I put in a ticket for it and it's a known issue that they're looking into.  It's driving us crazy as here we're not touch types and every time we look up, most of the conversation is at the start of the ticket, we then move it down and after a few words it shoots right back up again.

@elanaalex, We are sorry to hear that you are having a tough time in replying to tickets. 

Ideally, this shouldn’t be the case. Can you confirm if you're able to replicate the same in an incognito or any other private browser? Just to make sure that the cache isn't the issue, can we quickly clear the cache cookies from the browser and try to see if the same issue is being reproduced? 


If the issue still persists, even after performing the above troubleshooting, kindly help us with a video grab and send us an email to so that one of us would step in and resolve the issue from our end. 


Thanks for your understanding.