Linking to sections within a solution

  • 5 October 2022
  • 6 replies


Hello, I’ve put together a solution with a table at the top of my page that links to the various headings within the solution i.e. 

<a href="#anchor1">Receive Application</a> in my table links to the corresponding heading

<a id="anchor1">1) Receive Application</a>

Initially on saving, all the anchor links in my published solution work but then they quickly stop working, when looking back at the code within the solution, all my id=”anchor” tags are removed leaving just:

<a>1) Receive Application</a>

Is this a bug or am I doing something wrong?


6 replies

Userlevel 3
Badge +10



Welcome to the Freshworks Community! Are you seeing this in all articles, or did it happen only in this instance?


Anchor tags are working as expected; I also verified this on my test instance. Please let me know if this is happening in more than one instance. You can either post a comment here or share a private message, and we can debug this further.




Hi and thanks for your reply. 

At the moment I only have 1 solution making use of anchors so I’ve only seen this behaviour in that one instance. Currently the solution with the anchors is continuing to work as expected for now, however, I have noticed that if I attempt to edit the solution my id tags are all stripped from the HTML, which isn’t great if I need to make a small edit and find myself having to reimplement all the anchors each time.

Userlevel 3
Badge +10

That’s strange. I tried editing the links in my test instance and it worked as expected. 

If you’re still having issues with the anchor tags being stripped from the HTML, please share with us a videograb of the issue. You can email us at support(at)freshdesk(dot)com.



Thank you, I’ve sent an email with a video to the email address provided.

I’m seeing the same issue when creating a document. I’m currently trying to build a template our techs can use when creating documentation and after the initial save, any changes or attempts to open the document result in the ID tags being removed. 

Was a cause identified for this?


Hi hyland3r, I sent my findings to the support team who looked into it. It turns out that it is a bug that the development team have had to take a look at, but the fix is taking longer than expected (update to my last email received 07/11/22). I haven’t heard anything since so I assume they’re still looking to create and apply a fix.