MS Edge Copy Paste with Clipboard doesn't work

On our Windows 10 machines with latest updates, we can't copy paste text content into the message text window in a ticket. It doesn't appear anything. Sometimes with works after a few retries.

On Chrome it works.

This topic has been closed for comments

33 replies

This bug is reproducible in Mozilla Firefox too.

Userlevel 1


The issue , as we observed, happens with the latest versions of Firefox browser(v 55). Roll back to a previous version should solve this case . Having said that, we're also working on updating the UI behaviour w.r.t latest editions of all premium browsers.


No it doesn't. This problem was already occurring with the previous version of Mozilla Firefox I was using four weeks ago. I've just switched to Mozilla Firefox 55 today and the situation is identical. Moreover, according to the log messages, your own source code is to blame, there's a bad management of cross-domain requests.

Switching back to an older version of a web browser can't be an acceptable workaround as it exposes the end users to security flaws fixed in the latest version.

I have the same issue with Firefox (55.0.3)


Userlevel 1


We're hoping to push out a bug fix for this case in about 2 weeks time. Will keep you posted on any further developments on this case.


Userlevel 1

Hello everyone,

Glad to let you know that we've managed to fix the bug with the copy paste option in Firefox. Please run a check and drop us a note here in case if you notice any issues.


Userlevel 1

Sorry folks. We ran into last minute troubles and we'll try pushing this release to Monday. I'll confirm the status on Monday as soon we go ahead with the deployment. 


Userlevel 1


We've deployed the fix for majority of the accounts in one of our PODs. Please do check in your respective accounts and drop us a note in case if you're still seeing the issue.


 Thank you. It seems to work. I've just tested with Mozilla Firefox 55.0.3 32-bit.

Userlevel 1

Thanks for the confirmation,Julien. Happy Freshdesk-ing :)


now working for me..
thank you


now working for me ..


The original poster stated that this occurs with Edge. It still does.

This is not resolved. In this Freshdesk Mint dashboard, I am unable to paste any text I copy that wasn't copied within the ticket body itself using the Microsoft Edge browser.

Confirmed: unable to copy/paste from any source (notepad/notepad++) into the description/reply box using edge 43.17763. Seems to be something to do with the new line character as if you copy/paste just a single word it works fine, multi-line does not work. 


Also copy/paste from Word triggers a convert/strip prompt but neither of the options do anything, or close the window. Pressing ESC key is the only way to return back to ticket. 

Also the content in the Admin->Ticket fields page does not load.

Still cannot copy and paste if using the Edge browser. Please advise when this will be fixed.

I too find this extremely frustrating.

Ironically I can Paste into this edit addon when using Edge.

I am on Windows 10 using MS Edge. Copy & Paste isn't working and it's annoying.

Please fix or at least suggest a workaround.

I am using the latest Windows 10 and MS Edge version and copy&paste is not working. Please fix the issue!

This is marked as "Solved" so can anyone tell me how please?  Just want to copy and paste text into a Reply.  Using Windows 10 and Edge browser.  Have tried copying into Notebook first to remove formatting and then copying that but still doesn't work.  Seems like pretty basic function request for 2019.  Any help appreciated!  Thanks.

This is still NOT working for me. Windows 10, Microsoft Edge 44.18362.1.0 and/or Google Chrome version 76.0.3809.100 (Official Build) (64-bit).

BTW, I can copy anything within the same page (e.g., but I cannot copy pure text from notepad and paste in freshdesk.

Still now working for me. Windows 10 with latest Edge and/or Google Chrome.

BTW, I can copy anything within same page (e.g. but from notepad!

As a work around I found that if you open a Canned Response you can paste it in and then use that Canned Response to put the text into the ticket.

I simply called the Canned Response "Paste Buffer" so I can just reuse it as needed.

Still doesn't explain why it works there but not in the main ticket editor.

This has been solved in the new Edge (based on Chromium). You can try the beta if you like.