Question

Outgoing emails have no formatting in the plain text body

  • 9 May 2022
  • 5 replies
  • 112 views

Badge

When receiving an email as an external user from a Freshdesk ticket, the plain text body part of the email has no formatting (line breaks / blank lines between paragraphs).  The test is simply run together in a continuous stream (although with spaces between the words).

This makes the content of the message extremely difficult to read.

Does this mean something has not been configured correctly in a Freshdesk installation, or is this a bug in Freshdesk’s sending of multi-part emails, with both plain text and HTML body parts?


5 replies

Badge

Having just signed up to this forum in order to ask the question, I notice that the emails sent out by this system itself are even worse.  There is no plain text body part to them at all - only HTML.

In my organisation we have security restrictions on HTML email, therefore the plain text body part is essential.

Userlevel 4
Badge +5

Hi @PoohBear,

Welcome to the Freshworks Community!

I understand you are facing issues with the way emails are being rendered into fresh desk, there are only a few html supported tags within fresh desk currently, we are still working on improving our formatting to support varied content types within the product.

 

That being said, can you please help me with the .eml file of the email that does not render as expected in fresh desk through our DM, also a few screenshots would help, to raise this to our developers further and have a closer look into the same.

Cheers!

Badge

Thanks for your response.

Sorry, but I have no idea what a .eml file is - I assume it’s something internal to Freshdesk associated with EMaiL.  I also don’t know what DM means.

I attach a screenshot as requested - in this case, your message above as it arrived in my mail client.  As you can see, it contains only HTML with no plain text body part, and is therefore unreadable in a plain-text mail reader.

 

Badge

Here is another screenshot showing the original problem - this email does have both a plain text and an HTML body part (as shown in the lower window) but the plain text part (shown in the upper window) is run together making it extremely difficult to read.  The conversation shown should be on multiple lines each starting with the name of the person commenting.

 

Badge

Hi.

Surprised there’s been no further follow-up to this yet after I supplied the screenshots requested.  Does this mean you still need more information from us to investigate / reproduce the problem, or is it clearly just a mis-configuration of the system that’s sending these emails out?

If it’s the first, please let me know what else I can provide, to help get things fixed; if it’s the second, please give me some information I can pass on to the people who are running this system so they can configure it correctly.

As it is, it makes the support system extremely difficult for us to use (I think you can see from the screenshots), and we’re seriously considering changing supplier if they can’t send out reasonable emails.

 

Thanks.

Reply