Solved

Getting invalid_user error even after purchasing Blossom account

  • 21 February 2021
  • 1 reply
  • 3 views


HI Team,

I am getting below error when trying to reply on a ticket through the API with my client’s purchased account of freshdesk (Blossom), but it’s actually worked with 21 days trial account

{
"code": "invalid_user",
"message": "You are not authorized to perform this action on behalf of this user. id:%number%, name:%name%"
}

PLEASE RESPOND AS EARLY AS POSSIBLE.
PH:+91 7207298078
EMAIL: prakash.thoram@gmail.com
              prakash@myorigami.co

icon

Best answer by Keer 23 February 2021, 20:19

Hello Prakash, 

 

Good day! As far as we’ve seen, this error occurs when you attempt to make a call, to which you do not have access. 

Could you please let me know if you are indeed passing on your admin credentials right (for authentication) while trying to execute this call?


That said, Can you please try executing this API request using one of the other admin's API keys or user credentials and let us know if the same is successful?

 

That said, I have also logged in a ticket on your behalf to dig deeper into this issue. 

 

Cheers, 

Keer,

Freshworks Community Team.  

 

View original

1 reply

Hello Prakash, 

 

Good day! As far as we’ve seen, this error occurs when you attempt to make a call, to which you do not have access. 

Could you please let me know if you are indeed passing on your admin credentials right (for authentication) while trying to execute this call?


That said, Can you please try executing this API request using one of the other admin's API keys or user credentials and let us know if the same is successful?

 

That said, I have also logged in a ticket on your behalf to dig deeper into this issue. 

 

Cheers, 

Keer,

Freshworks Community Team.  

 

Reply