Don't scroll to bottom

  • 16 June 2016
  • 9 replies
  • 43 views


This seems to work without any adverse affects :) 


<script type="text/javascript">
TICKET_DETAILS_DATA.scroll_to_last = false
</script>


 



9 replies


This doesn't seem to be working



I figured out the issue. This is working when the ticket type is "Incident". But when the ticket is "Service Request" the scrolling is re-enabled. Anyway to fix this for "Service Request" types?



Sorry, it's been a while. When exactly does this behavior happen? When you view any request?  It just automatically scrolls down?



Also, this is what mine looks like currently. I added some stuff after posting this but cannot edit...




<script type="text/javascript">


  TICKET_DETAILS_DATA.scroll_to_last = false


</script>


<style type="text/css">


  #dont_scroll_to_bottom_388235 {


    display: none;


  }


</style>



When the ticket type is service request it scrolls down to the bottom. I have noticed that when the ticket type is Service Request, this gets added to the url "#requested_items" and this might be the reason why it's scrolling? Also please keep in mind that we are using another fresh plug called "Reverse Message Order" https://support.freshdesk.com/support/discussions/topics/311868 which i saw should disable the scrolling as well. Thanks for your help!







Do you have any other apps running that might get in the way?  Mine does not scroll to the bottom with Reverse Message Order enabled.  I also don't have a type of "Service Request", only "Request".  When I disabled RMO it then scrolled to the bottom again.



You don't have a ticket type called "Service Request"?



You don't have the ticket type called "Service Request"?





image





No, it's possible I renamed it.  The type really shouldn't be affecting this though, unless you have another script that is targeting tickets by type.


Reply