Cursor randomly jumps back to start in reply

  • 8 February 2018
  • 45 replies
  • 187 views


Using the new Mint interface for a while and quite like it, however recently it has started to do something odd in the reply box for ticket. The cursor seems to randomly jump to the start of the reply, before the Hi {name}, mid sentence.




Originally I thought I may have had a dodgy keyboard but it is also happening to a colleague of mine as well.




Any one else experiencing this?



45 replies

I recognise this. Not to the place you mention, but to the start of the note. Notice this most after including a canned response.

 



Yeah, I put in a ticket for it and it's a known issue that they're looking into.  It's driving us crazy as we're not touch typers and every time we look up, most of the conversation is at the start of the ticket, we then move it down and after a few words it shoots right back up again.


Folks,


This one's a very annoying little bug which in itself very inconsistent in showing up. We've identified a couple of instances where this issue can be recreated. You can expect a fix to be pushed to production soon. 


Any inconvenience is regretted.


Cheers!


I have the same issue in the exact place that you are experiencing it Kallen. Thank you Aravind for checking into this, since I basically live in Freshdesk it becomes quite annoying. 



Having the same issue here on multiple PCs. Looking forward to having this fixed.



Thank you, looking forward to the fix :)



Yes. happens to me too, on a Mac with latest OS running Safari. I can't type more than a sentence or two before the cursor jumps. It makes it really hard to answer tickets. Thanks for looking into this!





Would there happen to be a weekend push for development? Since this has to do with primary work and seems to inhibit us on our productivity would this be classified as a P1? 



Hi, we have just migrated to Freshdesk and find this bug very annoying. It gets my agents frustrated. As Violet Breeden wrote, please Freshdesk, can you give this a high priority? This bug interfers with my agents workflow in every single ticket. 




Thank you for any update on the matter.




Peter



Yes please as a matter of priority. I am force to write my replies in a notepad and copy paste as it is insanely disruptive. 


Hi everyone,


We've fixed this issue. The cursor shouldn't jump randomly anymore when you're composing replies or adding notes.


We're really sorry about the annoyance over the last week! Thank you for being patient with us while we worked to resolve this bug.


Shankar


Unfortunately, the problem is still occurring for me at this time.





Yep still happening for me too. Anything in particular we need to do on our end?


@Ronand Kallen : We had deployed a fix for the random movement of the cursor while typing out a reply. However, in case if you're trying to insert a canned response/solution, it might not end up in the likely position and that has already been acknowledged as a bug.


Try flushing out the browser cache/cookies and see if the issue still persists. If yes, please drop us a note here and we'll try to understand the trigger movement behind the issue in your helpdesk.


Cheers!

Hi Aravind, I have already submitted a Zoom video 2/23/18 on what I have been experiencing in an incognito widow. Would you like me to place it here as well? 


Hi Aravind, 


I have already submitted a video on when I try to insert a canned response 2/23/18. Would you like me to submit the Zoom video here as well?


No worries,Violet. I'll look into the support ticket. It looks as if the issue occurs when a canned response is inserted in the ticket reply - this has already been acknowledged as a bug and we have this right up on our priority list of items. 


Cheers!

Great! Thank you Aravind.


We're still having a lot of issues with the cursor randomly jumping around, as well. Any ETA on the fix?


@Violet, The bug with the cursor position on inserting a canned response has been fixed already. Please let us know if you're noticing any anomaly with the reply editor.


@Dave Can you please tell us a bit more about the issue? Does it happen when you click on the 'Reply' button or when you're already typing some text?


Cheers!

There seem to be several different issues. The cursor position when we hit "reply" seems random, even though we specifically set it in the Agent Reply Template. Sometimes it will be at the beginning, sometimes where we set it, and sometimes all the way at the bottom after the signature.


We also have issues with the cursor jumping around while we're typing a reply, which is by far the most frustrating problem. The agent will be typing a reply and suddenly the cursor jumps to the signature line and starts typing in the signature font at the bottom of the reply.


Lastly, when we insert canned responses, we will have issues where the inserted text seems to create a new paragraph. So if you wanted to type 2 sentences and then insert a 3rd in the same paragraph, you can't, the reply starts a whole new line. And then, when you try to back up and delete the space, you can't, it won't pull the inserted text into the prior paragraph. I don't know that it's directly related to the cursor moving around, but it's another issue that is bothering us with the reply editor.


Thanks for the quick reply, hoping the first two issues are resolved ASAP!

@Dave We've recently upgraded our editor to the latest available version. While that doesn't guarantee to fix all the bugs, it might add some stability to the performance of the editor. Can you please check and let us know if you're still seeing the cursor jumping around randomly in the editor?


Also, for the issue (3), do you use Firefox browser? We have seen this occur on Firefox mainly.


Cheers!

It definitely seems better, we'll keep an eye on it and update if we have any problems. Thanks!


Hello


I recognise the issue discussed in this forum, but from a different context. Since about a week ago I find when I start to write a new ticket, the cursor will jump back to the beginning, while I am typing, causing the text to appear jumbled.


Steven


Still happening here as well, not necessarily for canned responses, but definitely happens when we use ticket templates.


Reply