Solved

API issue with Priority | Postman | Freshservice

  • 9 April 2022
  • 7 replies
  • 148 views

Userlevel 1
Badge +1

Hello,

I am trying to make a ticket via Postman. As I define priority as value 4 which is Urgent in Postman. But as I create a ticket my ticket get priority as low which should happen, No workflow are working.

Also I have tried in new Instance and Same Problem. I am attaching some Image for reference

Check Priority

 

icon

Best answer by sanofar.allahpichai 11 April 2022, 16:00

View original

7 replies

Userlevel 4
Badge +6

Hi @adityatawade , can you make a POST request and check again. From the screenshot it looks like you are making a GET request that is ideally fetching all the tickets from the system.

Userlevel 1
Badge +1
API issue

 

 

Userlevel 7
Badge +14

Hello @adityatawade I ran through a few tests to see if I could replicate your issue and I also am getting tickets set to a low priority after I have changed the data I am sending in a POST request. This looks to be a bug. Best course is to raise a support ticket at support@freshservice.com. Also I would take this issue to the developer community here as they can get in touch with the team responsible for the Freshservice API. Tagging @sanofar.allahpichai since she has done a great job for us in the past in resolving technical issue regarding freshservice.

Let us know how it goes. Hope we can get this fixed.

Take care!

Userlevel 4
Badge +6

Hi @adityatawade,

Could you check if Priority Matrix is enabled in your account under Admin → Helpdesk Productivity. The Priority Matrix automatically sets the priority of the Incident ticket based on the Impact and Urgency.

 

 

 

 

 

 

 

 

 

Since you are not setting any values to the Impact and Urgency fields in your API call, they are taken as ‘Low’ (value 1) by default. You could either disable the priority matrix or include the “impact”:3 and “urgency”:3 attributes to your API payload and that should resolve the issue.

Thanks @zachary.king for looping us in. FYI.

Cheers!

Userlevel 7
Badge +14

Thank you @sanofar.allahpichai for taking a look at this. I made the adjustment you mentioned and that definitely fixed the issue on my side. Hope it does the same for @adityatawade

Thanks again!

Userlevel 7
Badge +14

@sanofar.allahpichai This does raise a question though 🤔 When I tested this I did so in a sandbox spun up from our production environment. In our production environment we do not have Priority Matrix enabled, so is there a reason why that setting is not replicated in the sandbox when it is built? I wasn’t aware that it would be reenabled and I have built workflow where, I feel like, that setting has negativity impacted its functionality when testing in the sandbox. Might be worth bringing up to the product team regarding a true representation of the production environment when creating a sandbox.

Thanks 🤗

Userlevel 1
Badge +1

Thanks for response, I have disable Priority Matrix and now its working fine 🚀

 @sanofar.allahpichai @zachary.king 

Reply