Departments Not Coming Through Azure SCIM App

  • 25 January 2023
  • 2 replies

Hi All,

Running in to a weird issue with our departments in Azure not pulling through we provision users through the Azure Active Directory Provisioning (SCIM) app. In looking through a test provision user notes, everything seems to be coming over ok (see below) but when I look at the users profile the department is still blank.

I have confirmed that the department moving over is in our list of departments, and I have tried setting it up a few different ways. i.e. just calling the target attribute ‘department’ or in the standard format of:


but nothing works. I also tried resetting all attributes to default mappings and still no go.

Any help would be appreciated!


2 replies


This is what works for us:




I wonder if the Characters in the department may be causing issues?

Userlevel 1
Badge +5

Test a mapping of a department name without any special characters in it.  I know there is an API issue with ampersands in department names and the bug was reported to the team.  No ETA from them yet.  I have to manually manage 3 large departments because of it unfortunately.