Solved

Editing Item Requested popup page

  • 15 September 2021
  • 13 replies
  • 84 views

Badge +1

Hi

Are we able to edit the ‘check out’ page that appears when you press the ‘place request’ button in the service catalog?

 

We have a scenario whereby for some of our service requests we don’t want to show the cost (or total cost) field to the requester when they are viewing the ‘Items requested’ page.

 

 

Thanks

Phil.

icon

Best answer by sanofar.allahpichai 19 October 2021, 15:33

View original

13 replies

Badge +1

Hi Sanofar

 

Thank you so much for this.

 

We’ve just implemented this and it has successfully fixed this issue.

 

Thanks

 

Phil.

Userlevel 3
Badge +6

Hi @pcooke,

 

Greetings!

 

We are aware of the behaviour and we will forward this to our product team. We understand that you wish to hide the Total Cost in the support portal v2 when the cost is 0 for a service item. For now please try this workaround:

Please navigate to Admin -> Helpdesk Rebranding -> Requester Portal Branding -> Customize Porta -> Layout & Pages and paste the below code at the bottom of Page Layout as shown below and click on Save & Publish.

 

Lg45se_4hFhA5c1JPJRNNB7rNW_4P2VAFjhaEqCLCDMPQVT45Ub46ZRat7wyLSVKtOdf7W-3op7SdwlfliNaYiTdmESWKn7H2uNd0MWgv9wo1ZBMeTuYLBuUbGDkdtPEX9nrMnq8=s1600

<script>  

  jQuery(document).on('SideModalOpen', function() {

setTimeout(function() {

  if (jQuery("#items-total-value").text()== '0.00'){jQuery(".total-section").hide(); }       });

   });   

</script>

 

We hope this helps. Cheers!

 

Warm Regards,

Sanofar

Team Freshservice

Badge +1

I’ve just created a brand new service object, purposely left the cost blank and the portal tick box unticked but once I published it and viewed on the customer portal it was still showing the empty cost unfortunately.

 

Like you say, i’ll have to raise a support ticket but thanks for your help in trying to get it sorted :)

 

Thanks

 

Phil.

Userlevel 4
Badge +8

I dug thru the html code on this page.  They have two div tags with logic “totalclear fix” when the price is > == 0$.  

At this point I would recommend opening a support ticket as this should be working. 

Userlevel 4
Badge +8

I will continue to mess around with my instance… I wonder if you create a new service object and set the visible in portal option to unchecked from the beginning if this still occurs???

 

 

Badge +1

Yeah, i’ve just tried it in an incognito window and the cost is still appearing

Userlevel 4
Badge +8

Looks good. I have tried to replicate your issue but have not been successful. I wonder is its a simple cache issue with your browser.  

Have you tried opening your site via a “incognito” window and checking it this still occurs?

Badge +1

Yeah sure, though please let me know if there is anything else in particular you want to see.

 

General details:

 

 

Service item settings:

 

 

When previewed (which does look promising as no cost is shown?) :

 

Userlevel 4
Badge +8

Interesting, would you mind sharing a couple of screen shots of your service item? I can check if their is any differences to my scenario. 

Badge +1

Hi

 

Unfortunately it is still showing the cost of 0.00 despite making that change and then publishing the new version of the service request to the catalog.

 

Thanks

Phil.

Userlevel 4
Badge +8

Awesome, I edited my post on how you obtain that. :grin:

Badge +1

Yep, the first screenshot is what we’re trying to achieve

Userlevel 4
Badge +8

Phil,

Two screen shots for you.  I believe the first screen shot is what you are trying to achieve? 

NOTE: To view larger imaged, right click the image and open in new tab.
 

 

 

To achieve this, navigate to admin, service catalog and then the item. Remove the cost and uncheck the visible in portal.

 

 

Reply