No results returned when querying Freshservice API

  • 19 December 2022
  • 1 reply

I have just started using Freshservice and am working with the API. I currently have a trial environment. I can query tickets in general and all 3 of the demo tickets appear. But whenever I try to query on a field I get no results. The query seems to be formatted according to the documentation, and if I intentionally format the query incorrectly I get an error. With this (below) I get no results even though there are several medium tickets.  I have tried all options for this and Status."priority:2"

1 reply

Userlevel 7
Badge +14

Hello @Trevor, I tried the query string you presented in my instance and was able to return results. Are you an Admin in freshservice? Using your API key when making the request? Are any of the fields that you are querying against hidden fields? Do you have workflow our business rules for forms interacting on the fields you are trying to query? If all looks good, I would contact support at to make sure there isn’t a bug associated with your freshservice instance. Sorry I wasn’t able to me of more help. Take care!