Question

Webpage Redirect in Solutions Articles


Userlevel 2
Badge +1

Hi

We have an existing IT Support wiki resource in SharePoint online. In an ideal world, I would like to create a “Solution” article in Freshservice with a title of “365 MFA” for example, but in the content of the Solution have it redirect to the corresponding SharePoint URL. Is this possible at all?

Users experience would be click on the Solution and be redirected to SharePoint page.


12 replies

Userlevel 6
Badge +12

Hello @mythumbsclick, I don’t believe that simply clicking the solution article can redirect users, but you can embed the URL in the solution article itself and by clicking that link it will take users to your Sharepoint location.

Hope that helps! Take care.

Userlevel 5
Badge +4

@mythumbsclick would using the article form external URL option meet your needs?

 

 

Userlevel 2
Badge +1

@keefe.andrews - Yes that looks like it could be exactly what I am after. I have noticed though that unlike creating a (local) article which populates the “Suggested Articles” column when I enter the subject of a new ticket in the portal, articles created in the Article from external URL don't appear in the suggested articles.

I have however found this that states:

Note: The external articles added will take upto 24 hours to be indexed in Freshservice’s search.  

I am now waiting 24 hours to test but can you confirm your experiences on this?

Userlevel 5
Badge +4

@mythumbsclick It does work for us 😀. Sample screenshot below. Using keywords with the KB entry also helps to prioritize it in the suggested articles results:
 

 

Userlevel 2
Badge +1

@keefe.andrews - The external articles i setup with keywords don't appear in related articles sadly. I raised this with support (via chat) who have stated there is a “feature request placed regarding this.” Pretty gutted to be honest as this was critical to have for us. 

In terms of your setup and why its working for you, are you using Freshservice or another Fresh product? 

Userlevel 5
Badge +4

@mythumbsclick we are using fresh service. Perhaps it loaded since the title matched and the keywords are the same by coincidence. 

Userlevel 2
Badge +1

That's so strange. I have copied your external url and keywords in my Freshservice and it still doesn't work. 

Before I go back to support, would you mind testing another new external URL Solution please?

 

How long a redirected blog takes time to index all of its links?

Userlevel 5
Badge +4

@mythumbsclick Looks like it did work for another external link. I made sure the subject did not have the title. 

 

 

How long a redirected blog takes time to index all of its links?

Thank you for showing your interest. You have provided a great information. 

Userlevel 3
Badge +4

That's so strange. I have copied your external url and keywords in my Freshservice and it still doesn't work. 

Before I go back to support, would you mind testing another new external URL Solution please?

 

I have a customer facing a similar symptom and there is a bug on external links as articles not populating. If you haven’t created a ticket, I would recommend doing so and also inquire about bug ticket FS-74001 to be associated with your ticket if support is unable to resolve it.  

Userlevel 2
Badge +1

@kcbates - Thanks!

I have noticed something interesting. publicly accessible external url solutions do appear and work such as the example powerbi from @keefe.andrews. What doesn't work is url’s that reference our SharePoint online site which is of course only accessible by my company.

Can anyone else confirm that's what they are experiencing? 

Reply