Solved

When remote authentication api is enabled (SSO), edit profile shouldn't display change password.

If user goes to edit profile, there is a box to change their password which doesn't work.  

It shouldn't be there.


3 people have this problem

Hey Blake,


Thank you for writing in to us here. 


Yes, I agree that the change password option shouldn't be there when the SSO is enabled. 


The team has been already notified of this and will be addressing it real soon. 


Thanks for your suggesstion and please keep it coming. 


Anna

Any updates regarding this issue?

I agree - password change feature should be removed if remote authentication / SSO enabled.  It would be confusing for customers.  Any timeframe when this will be addressed ?

 


Sorry for the delay in getting this addressed, guys. 


We sure have this in our list of issues to be addressed, but unfortunately, no solid ETA as of now. Our developers are swamped with developing features and bug fixes and we are trying to allocate resources based on priority. 


Hope you can understand. 


Anna

Jonathan / Stephen, 


I came up with a workaround using jquery or css I forget... basically to just hide them.  If you want me to dig it up, let me know.

Blake, 


It would be really helpful for our other users as well if you can dig it up and put it over here :)


Thanks,

Anna

If you have a version that supports portal customization you can comment out the following code in the header <!-- {{ portal | welcome_navigation }} --> and just insert  <a href="{{ portal.logout_url }}">Signout</a>.  This removes access to the entire user profile but it is one solution that I use as the user really doesn't need to access their profile information if using SSO.

 

If you want to show the user name you can insert the following:  {{portal.current_user}}

 


We had recently updated this functionality where in if a user or an agent logs in to the helpdesk portal via SSO, then the password options are disabled from the Profile Settings, irrespective of the plan.