Solved

FreshDesk SAML SSO with Google Apps

I am unable to get SSO to work with Google Apps. I receive an error 403, app_not_configured_for_user. Google informs me it is because FreshDesk doesn't support SAML 2.0 and SHA-256. I don't know if this is true but the guide FreshDesk has published for getting SSO to work with Google Apps is no longer accurate and was fairly vague in the first place.


So, if it is the case that FreshDesk doesn't support these protocols, when can we expect them to be implemented?


6 people have this problem

I learned that SHA-256 is required straight from the horse's mouth, one of Google's Support Employees.

I assume the situation remains the same, that despite the Google guide saying SHA-1 https://support.google.com/a/answer/6194926?hl=en  that SHA-256 is required by Google - hence getting the same error 403, app_not_configured_for_user


Was very excited - but now very disapointed.


I think ZenDesk works with Googel SSO - I'll give that a go.

Hi Alan,

 Please include https:// in the entity id and give it a try. It will work.



Thanks,
Shreyas

Yes  https:  in the app entry Entity ID worked - thanks

I had the same problem.

Alans hint to add "https://" to the Entity-ID in the google SAML settings worked for me too.


It would be a lot easier if the documentation would be updated:

https://support.freshdesk.com/support/solutions/articles/216696-how-to-enable-google-apps-sso-for-your-freshdesk-account


Also support for just uploading the IDP-metadata XML file I can download form google would ease the whole process a lot.



Thanks for the call-out,Gunter. We've updated the article with a note to include https:// in the entity-ID.


Cheers!