Solved

Reply Notification Problems

Something I have noticed which is causing some problems within my company:


Scenario:

  • Customer A initiates a ticket via email with Customer B as a CC recipient.
  • Agent responds to the ticket.  Customers A and B receive email.
  • Customer B responds to Agent's message.

When Customer B responds to the Agent's message, the blue "Customer Replied" label is not applied to the support ticket in the Agent's Tickets display.  I think this is because Customer B was not the initiator of the ticket.  Shouldn't the Agent be notified if Customer B replies to the ticket?  Their reply is often just as important as Customer A's.

I would appreciate you looking into this issue.

-Martin @ Spinnsoft


Edit:  This error only occurs when Customer B chooses to Reply All instead of just replying to the Agent

Hi Martin,


I'm reaching out to see if you were able to resolve this problem. I'm unable to see the behaviour you are describing with a difference between Reply vs Reply All.


Thanks,

Sudha




Hi Sudha,


This error is still happening for me.  Let me run down the scenario again.  Perhaps I missed something in the first try.


We have a client that sends in requests for new users to be added to her software program.  She sends the requests via email to our support email address (which creates a ticket) and also to our server technician (both in the to: field in her original email).  When our server technician replies all to the ticket (showing our client's email and our support email both in the to: field), the Customer Responded label does not show up on the ticket listed under "New and My Open Tickets"


I hope this helps.


-Martin

Hey Martin,


Thanks for explaining the scenario very clearly. 


We were able to reproduce this bug on our end, will keep you posted on the ETA for the fix.


In the meantime, what seems to happen is if the agent replies to the ticket once, subsequent responses from both customers are flagged correctly in the Ticket List view page.


Thanks,

Sudha


@sudha has any progress been made on this bug? I haven't heard anything lately.

Hey Martin,


We tried multiple scenarios and I am posting the results here:


1. Customer A sends an email to support address, copying Customer B(To: Support address; CC: Customer B). This email creates a ticket and the agent replies. Now Customer B replies to the agent's reply(Reply all). This reply gets added to the ticket. The 'Customer responded' flag gets added to the ticket on the ticket list page.


2. Customer A sends an email to support address, copying Customer B(To: Support address; CC: Customer B). This email creates a ticket and the agent replies. Now Customer B replies to the agent's reply(Reply). This reply gets added to the ticket. The 'Customer responded' flag gets added to the ticket on the ticket list page.


3. Customer A sends an email to support address and Customer B(To: Support address; To: Customer B). This email creates a ticket. No agent reply in this ticket. Now Customer B replies customer A's email(Reply-all). This reply gets added to the ticket. The ticket will still display the 'New' flag in the ticket list page, as there is no agent response so far.


4. Customer A sends an email to support address and Customer B(To: Support address; To: Customer B). This email creates a ticket. No agent reply in this ticket. Now Customer B replies customer A's email(Reply). The reply won't be appended to the ticket, since the support address is not in the loop


5.  Customer A sends an email to support address, copying Customer B(To: Support address; To: Customer B). This email creates a ticket. No agent reply in this ticket. Now Customer B replies customer A's email(Reply-all, both support address and customer A's address in TO:. This reply gets added to the ticket. The ticket will still display the 'New' flag in the ticket list page, as there is no agent response so far.


Basically, if the customer responds after a agent reply, it will display the Customer responded flag. Until that the ticket will be in New flag. Let me know if you want any other scenarios to be checked. 


Regards,

Bharghavi

Login or Signup to post a comment