Answered

The remote server returned an error: (400) Bad Request on api calls from yesterday

Its been some months I have been using freshdesk in my application.

Yesterday on wards am getting error The remote server returned an error: (400) Bad Request on API calls in both production instance and test. I haven't changed anything in code.


Best Answer

Thanks for the confirmation,Rahul :) Happy FreshDesk-ing ! 


Tip : In case if you're using V1 API s, please switch over to the reliable and more powerful V2 APIs with detailed error logs - API V2


Cheers!


I'm getting this as well I think.  any luck?

Hello ,


@Rahul


Sorry for the delay in updating this thread. Are you still facing the issue? If yes, please drop in a comment here and we shall take this forward.


@Paul


I have sent you an email requesting for additional details about the API call. Please check and let us know on how best we can help you :)

Cheers!



@Aravind, no it is fixed now.


@Paul 

The problem we had was with the json string which we are passing. One field which was passing created the error. Please check the field values which are passing and escape it properly. Mine was working fine and then this error showed up, may be some api changes from freshdesk 


Answer

Thanks for the confirmation,Rahul :) Happy FreshDesk-ing ! 


Tip : In case if you're using V1 API s, please switch over to the reliable and more powerful V2 APIs with detailed error logs - API V2


Cheers!

I received error 400 bad request when privacy is enabled happened after new upgrade

Login or Signup to post a comment