Solved

SSO Problems

I am setting up SSO, so a customer who has created an account in our Magento store is able to login with these credentials.

However, when a customer goes to the support portal and clicks on login, they are forwarded to an invalid address.

The address that they are forwarded to is www.zappautomation.net/https:/index/index/login/sso/


but it should go to this address.


http://www.zappautomation.net/freshdesk/sso/login


This address in the freshdesk sso settings in the security tab, as you can see in this screenshot.


http://prntscr.com/ghowmd



I have also tried it with SSL and without SSL and the address is the same.


This is a problem because if i log out, i am unable to log in again.




Hello Gary,


Thanks for posting this on our forums. The configs on the Freshdesk page seem to be setup right but I'm wondering if you had turned off  the SSO login on the helpdesk. I just tried to load the support portal and hit login expecting the re-direction to happen but it just loaded the Freshdesk default login.


Cheers!

I turned it off because i was unable to log back in after i logged out.

I have turned it back on in the freshdesk security tab.

Hello Gary,


I just tried to recreate this but looks like upon clicking the login button, it re-directs me to your store login . It took me to this URL : https://www.zappautomation.net/customer/account/login/


Cheers!

after i turned it back on, i tried to login again and the same problem happens.

try again and it will give a 404 error on our website


Hi Gary,


I tried this on a non-cached session but still I wasn't able to see any error. Here's the network log wherein you can see the re-direction happening successfully :


image



image



Can you please try accessing the login screen using Incognito mode ( Private browsing mode ) on the browser?


Cheers!

When i type http://www.zappautomation.net/freshdesk/sso/login into the browser i get forwarded to the http://www.zappautomation.net/https:/index/index/login/sso/


So do you think this is an issue with the freshdesk install in magento 2, rather than the freshdesk portal?

Incognito works and i get forwarded to the magento login page, where i am able to login as a customer.

However, once i am logged in, when i go back to the portal, i am unable to access as a logged in user.

I think that's the case,Gary. Going by the settings in the integration page , the SSO login seem to work correctly when it is accessed from the Freshdesk portal.


Cheers!

Ok, so it looks like the freshdesk module that is not working correctly.

I dont think freshdesk developed this module, so who do i contact regards this issue?

I will need to disable SSO for the moment because it does not seem to work on magento 2.


Hello Gary,


I'm converting this post into a support ticket to troubleshoot further on this case.


Cheers!

thanks

It still does not help me with activeing an account. I have now idea where to go or how to do it for an account if someone could walk me through it that would help me out a lot Robert David

@Robert : Can you please drop us a note on support@freshdesk.com? We'd be glad to help you out with your account issues.


Cheers!

Login or Signup to post a comment