Solved

Forwarding emails no longer puts in correct user

Hey,


When i use to forward an email to freshdesk it would know that the ticket should be created under the actual user and not my email address.


This no longer happens. Make it so!



1 person has this problem

The same problem as the language, by forwarding the email from the outlook on the web with an interface in Italian, it takes the name of the agent, setting the interface in English everything works correctly.

I'm a user from Germany and have experienced this issue, too. It seems, that Freshdesk scans the mail for the word "From:" followed by a name and/or an email address. Yet, the German version of Outlook uses the German word "Von" instead of the English "From". If I replace "Von" with "From", the same forwarded mail gets assigned to the correct sender. Otherwise (with "Von:") the ticket requester is me myself. Can anybody confirm that identifying the original sender depends on the existence of the "From:" phrase? And - if this is true - could you add a configuration option to the admin panel that allows to overwrite the "From" with the respective localized word?

 

Thanks in advance.

Bernd

 


I'm a user from Germany and have experienced this issue, too. It seems, that Freshdesk scans the mail for the word "From:" followed by a name and/or an email address. Yet, the German version of Outlook forwards like this: 


Von: Tom McRae <tom.mcrae@example.com> 
Gesendet: Donnerstag, 1. August 2019 16:41
An: Michael Moore <michael.moore@documentary.com>
Betreff: Z94.0 und T86.1

 

"Von" ist "From:" in Germany. If I replace "Von" with "From", the same forwarded mail gets assigned the correct sender. Otherwise the ticket requester is me myself. Can anybody confirm that identifying the original sender depends on the existence of the "From:" phrase? And - if this is true - could you add a configuration option to the admin panel that allows to overwrite the "From" with the respective localized word?

 

Thanks in advance.

Bernd

 


I was experiencing this as well. Sometimes forwarding an email worked correctly, adding the client's credentials, and sometime it would add my credentials. This thread helped me figure out that Microsoft Outlook will forward an email with either the client's email address alone in the From field, the client's email address and their name in the From field, or only the client's name in the From field.


As long as I make sure the the client's email address is visible in the From field I think this will function correctly.

Thanks, Mike. Happy to help, always :)

Cheers!

Hi Aravind


Thanks for the reply. I can see the forwarded part of the message, but it made me realise because I was forwarding an email from a colleague it didn't display their email address, only their name. I've just tested it with an email from an external party where the email address is visible and this works perfectly.


Thanks for the prompt to make me look closer! :-)


Mike

@Mike, Can you please check if you're able to see the forwarded message section on the ticket that carries the original sender's email?


---------- Forwarded message ---------
From: Aravind <aravind.s@freshworks.com>
Date: Wed, Nov 28, 2018 at 2:50 PM
Subject: Test email
To: <support@freshdesk.com>


Cheers!

I have encountered the same problem. An email forwarded from my work email account to Freshdesk in August worked perfectly and the requester was the person who had sent me the email in the first place. Now when I do the same thing I am shown as the requester (customer).


I have checked that the setting in Admin -> Email is switched on.


Any help would be appreciated.

Hello Gavin,


Welcome to the Freshdesk community. Congrats on your first post here :)


We haven't changed the behaviour, Gavin. Forwarding emails still work the same way as long as there's a reference to the original sender in the email. 


Can you please check if you have this option turned on under Admin -> Email section?  This is quite essential for Freshdesk to identify the original sender of the email.



If this is turned on but the ticket still gets created on your name, please check if the forwarded email has the reference to the original sender (in the description).


Cheers!

Login or Signup to post a comment