Solved

Backspace removes additional space after removing word

Hello,


I have an annoying issue where, when I delete a word using the backspace, the preceding space is also deleted.


The environment I am in is the description field, replying to or creating a new ticket. Please see the attached video.


Thanks,

Jason

mp4

43 people have this problem

When? For the love of god, when!? This ludicrous functionality has been incrementally picking away at my sanity, and now all the rage is nearly strong enough to break through. Please fi this so I don't Hulk the office, and the surrounding area!

This also explains why highlighting text with Ctrl + Shift + Arrow key behaves oddly.

@Aravind, can we get an update on the ETA for fix landing? This is starting to affect day to day operations and ticket completion times/quality. We have had a couple of occasions where replies to customers containing links were sent as broken links from words combining causing disruption and confusion.

This is affecting the quality of our support we can provide our customers, as it's affecting the quality of our responses, as well as response times.

Please give us a firm ETA on when you will be fixing this bug.

Hello,


We're looking to get this fixed with our next release that's scheduled to go out this week. I'll update this thread if I have any more information to share. Please bear with us.


Cheers!

Hi Aravind,

 

Well, last week you said "We're trying to get this pushed to production by this week and I'll share more updates as and when I hear from the team".

Nothing happened even though you had your "best engineers" working on this.

 

What is the problem???

@Per, We scraped the fix last week since it seemed to cause other conflicts with the editor. This time, we're working on a cleaner implementation and get this fixed in a few days' time.


Cheers!

Based on the link BRB posted earlier, the bug was confirmed as a bug in froala, and as of yesterday they provided a fix:

https://github.com/froala/wysiwyg-editor/commit/08eabdd976018ca756345a605cd8b737bd1a1eb5


It seems to be committed to master, so possibly updating the froala and using the htmlUntouched flag could possibly resolve the issue (obviously you have tons of testing to do, and I appreciate you aren't making huge changes without testing first).


Thanks for looking into this, hopefully the recent froala update will make resolving this easier.

Having the same issue, small problem but big time waster. 

Fixed for me with the new update, thanks to everyone who had a hand in it. Aravind, thanks for keeping us updated here, sterling work.

Yay!  Thanks for resolving this annoying bug!

Thanks Matt and Kirby. We have fixed the issue with the latest update :)


Cheers!

It works!!! I love the new look as well! Nice job!

I think it is still broken when using a Chrome on a Apple Mac