New editor has a few issues

Hi there! I just want to report a few issues we are experiencing with the new editor:


  • Pressing Control+K to open the link popup doesn't set the focus on the input field (the shortcut doesn't make much sense in this case, because you will have to use the mouse anyway to focus the input field)

  • Select any word and press Control+K to set a link. Enter an URL and confirm: the word will be transformed to a link, but the link will be moved to the very end of the editor! Notice this does not happen if you open the link function using the editor button (the problem happens only when using the Control+K shortcut)

  • Write a few words and try to delete the last one using the backspace key. When you delete the first letter of the last word, it inmediately also deletes the space that was between the deleted word and the previous one. This only happens in Chrome 71 (not in Firefox).


6 people have this problem

For that third issue, the backspace key bug, yes!! I thought I was going crazy. But I've tested on clean Chrome installations (with no extensions) and have the same problem. It is a constant source of frustration.

 

When can we get an editor that has the toolbar permanently on and not obscuring the editor window? To use any feature (such as colours, or orderered/unordered lists) you have to click a button to get to that popup toolbar. Then when you start typing your text falls behind the pop up so you have to turn it off again. The constant move from keyboard to mouse is frustrating and slowing us all down.

 


This issue has been around for far too long.  Why is Freshdesk unable to fix anything?

Login or Signup to post a comment