Ctrl-K to Insert Link Fails

Is else anyone having problems using Ctrl-K to insert a link in Mint?  It has been many, many weeks that I reported this issue yet it does not seem to be important enough to fix.  


If I click on "Insert Link" in the editor it works as expected.  The problem is that it takes two clicks to do that (Formatting options ► Insert link) and I prefer to use shortcuts.  Why should I have to take my hands off the keyboard and reach for the mouse?


So here are the issues I have when using Ctrl-K:


- Sometimes it just does not do anything.  If I press Ctrl-K on the first line of a note or reply it never works.


- If it does work, the cursor does not move to the field in the pop-up.  If I start to type, it closes the pop-up and just continues my text.  I have to use my mouse to click in the field, which defeats the purpose of the shortcut.


- Once I am actually able to click around and enter my text and URL, it inserts it at the end of the text.  Now I need to cut it and paste it where I wanted it to go in the text.


- Text I highlight before pressing Ctrl-K is ignored.



Am I the only one or are others having this issue?


image





2 people have this problem

This is being a major inconvenience for us. 
Our agents use a lot the feature of inserting and editing links, and this bug is having a considerable impact on our support performance. 

We experience the same issue: link is inserted at the end of the document.


Another annoying bug related to links is when you write a domain, for example, if I need to write "hello.com.br", the link is created when I type "hello.com" and ".br" ends up outside the link. Very very annoying behaviour. 

Good luck to us, @Santiago.  This has been an issue for many months but it does not seem to interest Freshdesk.  As usual, they are too busy developing new bugs to fix old ones.

@Gregg @Santiago, I often use CMD+K to insert links in replies and I can understand how frustrating the experience has been so far, with all the bugs in the 'Insert Link' option. We're sorry for leaving this productivity bummer for a long time. 


These issues have been prioritised already and as I'm writing this, we already have a developer working on the fix. You can expect this to be rolled out within the next few releases and I'll share the expected release date shortly.


Cheers!

BTW - This works fine in the old Freshdesk.  After all the problems and bugs, I have switched back to using the classic Freshdesk to avoid wasting time all day long.

Login or Signup to post a comment