Google Logins Denied

Hi Support


I've been a Freshdesk customer for some time and have always used Google's authentication but I've been denied access for over two days now. It doesn't matter whether I use the customer or agent login, the result is the same.


I usually use Google Chrome, on Windows 10, but have also tried Microsoft Edge, Internet Explorer and Mozilla Firefox, all with the same result. I've cleared caches, cleaned temporary internet files and using Private Browsing.


Without access to any log files, I can't give you any more information. Is there a known issue with Google authentication at the moment?


Regards


Alan Rogers

DreamGenius Ltd


2 people have this problem

Hello Alan,


We've tried logging into Freshdesk by using Google SSO and it's working for us. Could you please confirm if the issue was fixed, or if you are still facing it?


In case you're still seeing an error screen, please do let us know what error you are seeing so that we can help identify the right solution for it.

We are experiencing the same thing.  No errors just constant redirects back to the login page.  I press the "login using google" button or the agent login link which redirects to a freshworks.com login page, again with a "sign in with google" button.  Clicking that sends me to Google's authentication page, but after authenticating I'm sent directly back to our landing page to login again with "You are not allowed to access this page!".

We are experiencing the same thing.  It's a constant loop back to the landing page.


  1. Try to login with google or use the agent login link
  2. Redirect to freshworks.com login page with another login with google button
  3. Authenticate with google
  4. Redirect back to landing page with "You are not allowed to access this page!"

Hello @Alan and @Bkramer,


We apologize for the bad experience that you are facing. A few other customers have faced similar login issues with SSO, and we're working on resolving it. Until then, please try logging in using your respective username and password.

Hello @Alan and @Bkramer,


We've rolled out a fix for this issue.


Could you please try logging using Google SSO and see if you are able to login now?

Working great now!

Hi there! I'm encountering a very similar issue today. Is there a possibility that this is recurring?

Login or Signup to post a comment