SSO for Contacts

Hi,


How can I enable SSO into Freshdesk for my Contacts?


Currently, when I try to configure SSO by navigating to Admin > Security >Single Sign On (SSO) from my Freshdesk panel, I am being redirected to Freshworks and it seems only Agents are visible as Users here, not my contacts.


I appreciate your help!


7 people have this question

Thanks for the recommendations
Had the same problem

AMOS - No, Freshdesk did nothing. It was in how I configured my end. The key is building  2 enterprise apps in Azure correctly, one for Agents and the other for contacts. One uses the built in Freshdesk app, the other a CUSTOM enterprise app.  Then having two Security profiles in Freshdesk. Each one pointing to a different enterprise app in Azure. I used the default profile for agents and created the custom one for contacts. I am assuming you could use the default one for contacts and the custom one for agents, but i already had them built and it's working so i didn't want to change them.  Make sure you also have people in your AAD allowed access to those enterprise apps in Azure or it will fail. 

I was able to successfully set up SSO for my Contacts using miniOrange SSO plugin for my WordPress site.

https://wordpress.org/plugins/miniorange-wp-as-saml-idp/


I have seen that these folks provide similar SSO solutions for platforms other than WordPress as well.

I totally recommend miniOrange if you need help with setting up SSO for your Freshdesk contacts or agents.


Thanks.

Login or Signup to post a comment