Solved

Azure AD Provisiong Failure

  • 29 July 2022
  • 5 replies
  • 959 views

Userlevel 1

First all users were created but now get an for forbidden for every try.

 

EntrySynchronizationError

Ergebnis

Failure

Beschreibung

Failed to match an entry in the source and target systems User 'PB@mink-buersten.com'

ErrorCode

SystemForCrossDomainIdentityManagementClientNonServiceFailure

ErrorMessage

Received response from Web resource. Resource: https://scim.freshservice.com/scim/v2/Users?filter=userName+eq+"PB%40mink-buersten.com" Operation: GET Response Status Code: Forbidden Response Headers: Connection: keep-alive Access-Control-Allow-Origin: * Access-Control-Allow-Methods: GET, POST, OPTIONS, PUT, PATCH, DELETE Access-Control-Allow-Headers: X-Requested-With,content-type,Authorization Access-Control-Allow-Credentials: true Date: Thu, 28 Jul 2022 20:48:18 GMT ETag: W/"60-qiag1d2/y4DPf/mU08+UKnN3p+Y" Server: nginx/1.10.3 (Ubuntu) X-Powered-By: Express Response Content: {"schemas":["urn:ietf:params:scim:api:messages:2.0:Error"],"detail":"Oops! Some error occurred"} . This operation was retried 2 times. It will be retried again after this date: 2022-07-29T08:48:18.2535741Z UTC

 

Did anyone have the same problem?

 

Thanks

icon

Best answer by Champ2910 5 July 2023, 12:13

View original

5 replies

Userlevel 7
Badge +16

Hello @pb1994  and @chicc0 Let me tag @sanofar.allahpichai. Maybe she can help get the error messages in front of the product teams and see what the issue may be.

Hi,

Same for us with a similar error message in the azure portal

 

Received response from Web resource. Resource: https://scim.freshservice.com/scim/v2/Users?filter=userName+eq+"x.xxxxxxxxxxxxx%40[ourdomain].com" Operation: GET Response Status Code: Forbidden Response Headers: Connection: keep-alive Access-Control-Allow-Origin: * Access-Control-Allow-Methods: GET, POST, OPTIONS, PUT, PATCH, DELETE Access-Control-Allow-Headers: X-Requested-With,content-type,Authorization Access-Control-Allow-Credentials: true Date: Mon, 19 Sep 2022 09:26:20 GMT ETag: W/"60-qiag1d2/y4DPf/mU08+UKnN3p+Y" Server: nginx/1.10.3 (Ubuntu) X-Powered-By: Express Response Content: {"schemas":["urn:ietf:params:scim:api:messages:2.0:Error"],"detail":"Oops! Some error occurred"}

 

I checked the login credentials (AzureAD => freshservice) and getting a OK

Have very similar error. Nothing I changed allowed to sync the users.

I had the same problem and the good people from effy who created the app suggested this:
 

1. If the Admin Agent was temporarily deactivated and can be reactivated, we would suggest that you reactivate the agent.

2. If the Admin Agent was deactivated and cannot be reactivated, you might have to uninstall the Azure Provisioning (SCIM) inside *Freshservice Admin > Apps*, and reinstall it with a new Org Admin / Account Admin API key. You would receive a new Bearer Token which should be pasted in *Freshservice Provisioning app > Provisioning* inside Azure. You do not have to uninstall the app on Azure.

Solution 2 solved it for us. The user who originally configured SCIM was no longer working for the company and his account was deleted in Freshservice.

 

I had the same problem and the good people from effy who created the app suggested this:
 

1. If the Admin Agent was temporarily deactivated and can be reactivated, we would suggest that you reactivate the agent.

2. If the Admin Agent was deactivated and cannot be reactivated, you might have to uninstall the Azure Provisioning (SCIM) inside *Freshservice Admin > Apps*, and reinstall it with a new Org Admin / Account Admin API key. You would receive a new Bearer Token which should be pasted in *Freshservice Provisioning app > Provisioning* inside Azure. You do not have to uninstall the app on Azure.

Solution 2 solved it for us. The user who originally configured SCIM was no longer working for the company and his account was deleted in Freshservice.

 

Yeah, I reinstalled the app too and it worked. Thanks!

Reply