Jira Login Failed


Im having trouble setting up the Jira Integration, Im 100% sure that username and password are correct, i've logged out of Jira and logged back in using the same credentials im trying to use here, but when i try to enable the integration i keep getting "Login Failed"

Do i have to change any config on Jira?, Any ideas?



This topic has been closed for comments

12 replies

I am having the same problem, please advise

Same problem, the screen message says "Jira reporting error - can not process request" this means nothing other than it can't process a request. What actually is not processing?

Most likely credentials problem. Check for valid username, domain and  password.It should be admin user in Jira. Please make sure you have entered jira admin username   and not admin email.

Can you also tell if its on-premise account or cloud jira account??


Trying to install Jira, used my login credentials which are at admin level. Pressed enable, and was presented with the following message "jira reports the following error : Cannot process your request" The account is held on an in-house server


Userlevel 4
Badge +12


In most cases, we observe that this arises due to incorrect credentials entered in the integration page. Please verify the domain name, user name and password and try updating the app again. Note that you'll have to input user name of the admin and not the email address .

Also, in case of On-premise versions of JIRA, you'll have to open up the site to public access ( you can setup a ngrok tunnel to securely allow access ) . In case if your JIRA instance is behind a firewall, the Freshdesk IPs have to be whitelisted for us to connect to the app.

You can find more information about the IPs here . Also, if the JIRA instance is accessible only through a particular port, you'll have to specify the port number in the integration setting.

domain name : port number

ex : mycompany.atlassian.com/jira:443

Should you have any troubles connecting to JIRA despite these measures, please shoot us an email on support@freshdesk.com . We'll have our technical experts work on the issue straightaway.


same problem:

created a ticket - #3074051 in support.freshdesk.com

and #3073886 in support.freshservice.com

We created an admin account in jira - managed to logon to jira, so Credentials are OK.

When trying to setup Atlassian Jira app in Freshservice admin - it throws an error:

jira reports the following error : Cannot process your request

Also tested with another jira admin account.

Please help.

I tried using my admin email and my admin username (my full name) and nothing works. Im still getting the following error message : jira reports the following error : Login failed

If the username isnt my full name where can i get my username?

Im sure Im using the correct info.


Looks like Atlassian Jira have been phasing out the use of usernames:


I'd say that's why my integration has stopped working, and I can't authenticate the plugin.

It looks like Atlassian Jira have been phasing out usernames:


My plugin stopped working too.  I'm looking at the Freshdesk plugins now, and see there are two Jira plugins, "Atlassian Jira" (published 3 years ago), and "Atlassian Jira Plus" (published 3 months ago).  I've about to try installed the Plus to see how it goes.

I have had a ticket logged for this issue for almost 4 weeks! I wish in all this time they had mentioned this isnt unique to me. I have been making unending changes at my end to figure out why.

I feel your pain.  It took me a while to figure it all out.  You definitely need to be using the Jira Plus addon now, as far as I can tell the old one won't work any more and really should be removed.

Secondly you need to sort out Webhook permissions.  Not sure about the demotion from Global though, I've still got a few updating issues I haven't spent time tracking down.

Thirdly you need to have a matching plugin installed in Jira (https://marketplace.atlassian.com/apps/1219916/freshdesk-for-jira?hosting=cloud&tab=overview).  The new replacement plugin only does half the job the previous one did.

I told them their documentation on this was sub-par 2 months ago, nothing has changed.

We have just managed to install the updated Jira Plus plugin for our on-premise Jira instance. Whereas the old plugin installed straight away, the Plus version threw a "Check your JIRA credential" error even though we knew the credentials were 100% correct and worked for the old plugin.

Turned out there was a certificate snafu on our side - we found this out when our network guy installed an intermediate certificate to address a seemingly unrelated auth issue with our Confluence server. That not only fixed Confluence, but the connection from Freshdesk as well!