Filter tickets not working

  • 16 November 2017
  • 1 reply
  • 28 views


I'm using the search filter as follows:




api/v2/search/tickets?query="(status:2 OR status:3 OR status:4)"




In my test this returns 2 tickets.  If I close one ticket and re-run the search it still returns both tickets, even though the status of one is 5 (closed).  See below (I've removed the email fields from the results).  See the value or status.




If I run the search again after a few minutes then only one records is returned so it looks like it is a caching issue.




    "results": [


        {


            "fr_escalated": false,


            "spam": false,


            "email_config_id": 35000016792,


            "group_id": 35000047658,


            "priority": 2,


            "requester_id": 35000926513,


            "responder_id": null,


            "source": 1,


            "company_id": null,


            "status": 5,


            "subject": "Test 2",


            "product_id": null,


            "id": 164,


            "type": null,


            "due_by": "2017-11-16T00:09:27Z",


            "fr_due_by": "2017-11-12T04:09:27Z",


            "is_escalated": false,





This topic has been closed for comments

1 reply

I'm seeing the same issue, only mine doesn't appear to be down to caching.


If I request one status, it seems to work, if I request multiple I get tickets with status values that don't match.


Some of these tickets haven't been updated for a long time, so its not that they have just been closed. So old I'm not entirely sure why they haven't been auto-archived.