Redirect_uri problem with Freshsales

  • 1 November 2018
  • 0 replies
  • 10 views

Hello.

I'm trying to make an Freshsales app and I need to make an Oauth authentication, but I've got some problems.


First: the authorize_url should be:

https://app.rdstation.com.br/api/platform/auth?client_id={{my_client_id}}&redirect_url=http://localhost:10001/auth/callback&response_type=code&state={{state}}

Look at the redirect_urlĀ parameter. This URL shows the authorization page.


But, when I click on the "Authorize" button in my app, it redirects me to the following URL:

https://app.rdstation.com.br/api/platform/auth?client_id={{my_client_id}}&redirect_uri=http://localhost:10001/auth/callback&response_type=code&state={{state}}


Look at the same parameter again. The app changes the parameter to redirect_uriĀ and it returns the following message:

"Invalid parameter: redirect_url"


How can I change this parameter to open the first URL?

Thanks!!



This topic has been closed for comments