Solved

Web Request in Workflow, waiting for Web Request Response

  • 6 October 2021
  • 2 replies
  • 35 views

Badge

Hi all,

with the new Web-Request Node, in the Workflow-Automater, i create a Api-Call.

While testing, everything seems to be ok, i get response and data from the call.

 

Now the Automater is active, and is triggered when a new Ticket is created but

in the Ticket Activities the Automater stops at: Waiting for Event Web Request Response.

Are there some Waiting Limits?

Someone any idea?

Thanks,

Stefan

icon

Best answer by sanofar.allahpichai 19 October 2021, 17:14

View original

2 replies

Userlevel 2
Badge +5

Hi @Stefan.Roll,

Good day!
 

Are there any errors in the workflow execution logs? Please navigate to Admin → Workflow Automator and open the affected workflow → Click on ‘Execution Logs’ on the top right. The API call-back URL, payload passes and response received will be shown there. This should help you identify and resolve the issue better.

If the issue persists, please help us with the name of the workflow and the affected ticket IDs so we can ask our support team to troubleshoot the issue further.

 

Warm Regards,
Sanofar
Team Freshservice

Badge

Hello @sanofar.allahpichai 


thanks for your reply.

The error was on my side because I assumed that the placeholder for the ticket ID contains the pure number.

My API has checked for this. Which I sent in the header of the request to my API.

But as I noticed, the placeholder sends the ticket ID including the ticket type (INC, SR ...)

Now everything works as expected.

Best regards,

Stefan

Reply