Fuzzy Service Catalog Item Images

  • 24 August 2017
  • 6 replies

We are having trouble getting crisp images uploaded onto the Service Catalog items we create.

We uploaded a 130x130 image, we tried increasing the size / resolution, changing contrast settings, we even had support help us with configuring the image.

Still fuzzy.

What is really strange is if we "Change Image" the preview is crystal clear, it only becomes distorted when we save the item (draft or published, doesn't matter).

Anyone else experiencing this or have a workaround?


This topic has been closed for comments

6 replies

Hi Noah,

Can you try uploading the images with resolution, 100x100 and all thumbnail images that we use are 1:1 ratio of height and width, so as long as the images are square with minimum of 100 pixels, it should be uploaded without any issues.

Please let me know if that helps!



Hi Suvashini,

Sorry just saw this update. I have tried your suggestion with multiple images and still, no clarity on the issue (see what I did there?) Anyway, hope we can figure this out.

Thank you!


So, I uploaded an image at 130x130, and I pulled it back down from AWS. Looks like FS scales the image down to 127x127 before uploading, but displays the image at 130x130...

That might be a good place to start @FreshService.

Any update here?

Any update with this? The resolution needs to be included into a tutorial on Fresh Service.

Userlevel 1


Images with 260x260 resolution should display fine when uploaded against service items.