GSuite -Orch and Workflow Automation

  • 27 February 2022
  • 7 replies

Has anyone been able to configure the GSuite - Orch correctly?  I went through the documentation (which is a bit outdated, so I had to make some guesses at how to configure a few things) and configured the app.  But when try to test the App in a workflow I get the error shown below every time I run it.  Has anyone been able to get the GSuite - Orch app to run successfully?



7 replies


Hi @scottblauer from the error you are getting looks like the private_key was not properly copied from GSuite Service account json created and configured in app. So can you do that and check once.


@atulaggarwal where do you get the info that the private_key is incorrect?

I get the same error - I’ll paste the error code in text so people can search as well:







Illegal base64 character 22




The documentation here says to make sure that you include the “keyhere” including the comma at the end ,

I’ve tried this with and without for the private_key_id and private_key in every combination

It would be nice to be able to have a test connection happen when you’re setting up the app so you don’t have to muck around trying to figure out if it connects or not!

Log return does’t even lend info if its connected or not

"message": "Response:: {\"meta\":{\"exit-code\":0,\"message\":\"success\",\"route_id\":\"service.request_service_sync_api\",\"user_message\":\"User message not set for key: user_messages.service.request_service_sync_api.0\"},\"result\":{\"result\":{\"metadata\":{\"osr_name\":null,\"account_id\":455090,\"preview_code\":\"ticket_51000264275_70003\",\"app_id\":\"31680\",\"config_name\":\"GsuiteTest\",\"pod\":\"podeucentral1\",\"region\":\"eu-central-1\",\"start_time\":\"2022-04-08T04:09:56.705Z\",\"app_name\":\"GSuite - Orch\",\"app_action\":\"Get User\",\"success\":false,\"minutes_saved\":5,\"status\":\"completed_with_errors\",\"end_time\":\"2022-04-08T04:09:57Z\"},\"output\":{\"meta\":{\"status_code\":400,\"system_message\":\"Illegal base64 character 22\",\"status\":\"completed_with_errors\",\"success\":false}}},\"message\":\"Illegal base64 character 22\",\"user_message\":\"Illegal base64 character 22\",\"exit-code\":-1}}"


I wasn’t able to find much but I’m using a get user request - and the only thing I can now think of is that the user_key is calling incorrect since it should be calling userkey? maybe I’ve already spent too much time on this and have gone crazy


I’m curious if anyone is also using this successfully - its kinda the last piece of the puzzle when it comes to fully automated onboarding my side.  


So the above error is generally a Java error which we get while encoding the Private key at backend and I have observed this for many customers who doesn’t give Private key properly since one need to copy the whole private key properly given inside double quotes from Service Account json file otherwise this error occur.

So an example of private key to be given in input would be like this starting from ------ BEGIN PRIVATE KEY and ending with ---END PRIVATE KEY----\n as shown in below image. So please check if you have copied and entered it full.



 @seafood47 hope the above reply help you out in resolving the issue. If anything else is there please do let me know.


I’m facing the same issue and I copied the private_key as mentioned above and still get “Illegal base64 character 22” any idea what more can cause this issue?


@orlym The above issue is observed only when the private key is not properly copied and given in app config. As even a single character missing or added extra can cause this issue.


Hey everyone, 

I’ve finally figured out what the problem was - and like the above replies, when entering the private key, you need to paste in the entire key without quotes (unfortunately the instructions here are incorrect)

Added to this, in the ‘email’ field, I had to enter my own email address - I’m really not sure why but I am the owner of the google project, but I also had a service account (in this case, but I would still get an error unless I used my own email address.

It’s been really getting to me for how long it took but super happy that it’s finally working!